Card processing through Evry to Wordline and Elavon is currently experiencing problems
Incident Report for Reepay
Resolved
This incident has been resolved.
Posted Apr 17, 2024 - 00:30 CEST
Monitoring
Processing through Evry to Wordline and Elavon is currently experiencing problems. We are monitoring the situation and will report when we receive updates from Evry.
Posted Apr 17, 2024 - 00:14 CEST
This incident affected: 3rd Party - Card Acquiring (Elavon (Evry), Worldline (Evry)).