Visa Secure (3D Secure) is experiencing problems
Incident Report for Reepay
Resolved
This incident has been resolved.
Posted May 23, 2023 - 08:26 CEST
Monitoring
Visa Secure (3D Secure) is currently experiencing problems. We are seeing a high ratio of processing errors for 3D Secure for Visa, affecting card payments and signups using Visa. We are trying to reach out to our 3D Service provider and Visa.
Posted May 23, 2023 - 07:40 CEST
This incident affected: Strong Customer Authentication (3D Secure).