MobilePay Online is experiencing problems
Incident Report for Reepay
Resolved
MobilePay has resolved the incidence. MobilePay payments was declined from approximately 12:03 to 12:20 CEST.
Posted Apr 09, 2021 - 12:23 CEST
Identified
MobilePay Online is currently experiencing problems
Posted Apr 09, 2021 - 12:13 CEST
This incident affected: 3rd Party - Payment Methods (MobilePay Online).