Acquirer Nets is experiencing problems
Incident Report for Reepay
Postmortem

At 2024-06-02 02:15 CEST we received an alarm from our surveillance that Nets transactions were failing with a processing error. We quickly determined that that the Nets server certificate had expired at 00:00 UTC. We contacted Nets command bridge and they started their own investigation.

At 02:45 We started investigating ways to temporarily bypass certificate validation and considered the security impacts. It was assessed that the security impact was acceptable compared to the business impact of failing transactions for a prolonged period.

At 03:23 CEST Nets also concluded that the server certificate had expired. From the dialogue with Nets it seemed clear that Nets would not be able to solve this issue within an acceptable timeframe.

At 04:33 CEST we released a change so certificate validation was bypassed. Transactions was processed again.

Nets have now renewed the certificate and we have removed the temporary certificate check bypass.

We are in dialogue with Nets to make sure that situations like this does not occur again.

Best regards, Billwerk+ Pay

Posted Jun 03, 2024 - 15:14 CEST

Resolved
This incident has been resolved.
Posted Jun 02, 2024 - 06:35 CEST
Monitoring
A temporary fix to handle expired certificate has been put in place. Transactions is now processed again. Awaiting a durable resolution from Nets.
Posted Jun 02, 2024 - 04:38 CEST
Identified
Nets have identified an expired certificate causing the issue. No estimate on a resolution has been given.
Posted Jun 02, 2024 - 03:35 CEST
Update
We are in contact which Nets. They are investigating the issue. All transactions towards Nets have failed since 02.00 CET.
Posted Jun 02, 2024 - 03:01 CEST
Investigating
The acquirer Nets is currently experiencing problems. The problem affects card sign-ups and payments for merchant accounts using Nets as acquirer and as processor towards Elavon, Swedbank, Valitor and Bambora.
Posted Jun 02, 2024 - 02:28 CEST
This incident affected: 3rd Party - Card Acquiring (Nets, Swedbank (Nets), Elavon (Nets), Bambora (Nets), Valitor (Nets)).