Reepay website down - no services affected
Incident Report for Reepay
Resolved
reepay.com is up again.
Posted Nov 13, 2022 - 19:05 CET
Identified
The reepay website (https://reepay.com) is currently down. We have identified the problem and are working to get it up and running as soon as possible.

No services are affected. If you are using the website to log into the reepay admin. You can go directly to the admin following this link: https://app.reepay.com
Posted Nov 13, 2022 - 18:49 CET