MobilePay Subscriptions is experiencing problems
Incident Report for Reepay
Resolved
This incident has been resolved.
Posted Apr 04, 2024 - 15:47 CEST
Identified
MobilePay Subscriptions is experiencing problems resulting in delayed payment processing. MobilePay are working on a fix.
Posted Apr 04, 2024 - 13:30 CEST
This incident affected: 3rd Party - Payment Methods (MobilePay Subscriptions).