Checkout API timeouts
Incident Report for Reepay
Resolved
The root cause of the incident has been identified as an out of memory issue for the service entities. Recent changes to the service has slightly changed the memory consumption profile of the service, making it exhaust memory. Unhealthy service instances was automatically deprovisioned and new ones started, resolving the issue. The resource allocation has now been adjusted and monitoring put in place to discover potential resource starvation before the services become unresponsive.

We apologize for the inconvenience this may have caused.
Posted Nov 12, 2024 - 15:34 CET
Monitoring
From 10.15 to 10.21 CET we saw connection problems between load balancers and the Checkout API service, resulting in timeouts. We are currently investigating the cause of the problems. The service is now operating as normal.
Posted Nov 12, 2024 - 10:53 CET
This incident affected: Checkout.