Card issuer Nordea is experiencing problems with Visa cards
Incident Report for Reepay
Resolved
This incident has been resolved.
Posted Nov 09, 2023 - 09:49 CET
Monitoring
Currently we see an increased number of processing errors for Visa cards issued by nordic issuer Nordea. Card prefix: 402620. The issue affects payments with card and wallet payments (MobilePay, Apple Pay and Google Pay). We will monitor the situation.
Posted Nov 09, 2023 - 07:20 CET