3D Secure for Mastercard experiencing problems
Incident Report for Reepay
Resolved
Mastercard has resolved the issue
Posted Apr 06, 2021 - 20:31 CEST
Monitoring
Mastercard is suffering from an outage affecting 3D Secure for all Mastercards. We will monitor the situation.
Posted Apr 06, 2021 - 20:08 CEST
Identified
3D Secure for Mastercard is currently experiencing problems
Posted Apr 06, 2021 - 19:54 CEST
This incident affected: Strong Customer Authentication (3D Secure).