Processing through Evry to Elavon and Handelsebanken is currently experiencing problems
Incident Report for Reepay
Resolved
This incident has been resolved.
Posted Jun 13, 2021 - 08:19 CEST
Identified
Processing through Evry to Elavon and Handelsebanken is currently experiencing problems. We will monitor the situation and report when we receive updates from Evry.
Posted Jun 13, 2021 - 07:46 CEST
This incident affected: 3rd Party - Card Acquiring (Elavon (Evry), Worldline (Evry)).