DIBS payment service provider is experiencing problems
Incident Report for Reepay
Resolved
This incident has been resolved.
Posted Nov 27, 2019 - 07:59 CET
Monitoring
The payment service provider DIBS currently has an outage. The problem affects card signups card updates, on-demand invoices and charges, and refunds for accounts having acquiring through DIBS. We will monitor the problem and report when DIBS have resolved the problem.
Posted Nov 27, 2019 - 06:45 CET
This incident affected: 3rd Party - Acquiring (DIBS).