Alternative payment methods experiencing problems
Incident Report for Reepay
Resolved
This incident has been resolved.
Posted Jul 01, 2024 - 22:05 CEST
Update
We are continuing to investigate this issue.
Posted Jul 01, 2024 - 21:07 CEST
Investigating
Payment proxy PPRO is experiencing problems affecting multiple alternative payment methods as SEPA Direct Debit, Verkkopankki, iDeal and GiroPay.
Posted Jul 01, 2024 - 20:47 CEST
This incident affected: 3rd Party - Payment Methods (Verkkopankki, SEPA Direct Debit).