Card processing through Evry to Wordline and Elavon is currently experiencing problems
Incident Report for Reepay
Resolved
This incident has been resolved.
Posted Sep 18, 2023 - 12:15 CEST
Investigating
Processing through Evry to Wordline and Elavon is currently experiencing problems. We are investigation the issue.
Posted Sep 18, 2023 - 11:46 CEST
This incident affected: 3rd Party - Card Acquiring (Elavon (Evry), Worldline (Evry)).